Issues with running mcmc function


#1

I am trying to run the example from the website and running into the error in the picture below. Seems to be a python error, but I am not sure how to fix it.


#2

Hey, I think that’s an installation issue, since the example works fine for me. Could you post your sessionInfo() and the tensorflow/tfp versions you’re using, please?


#3

Thanks for responding. I have a new problem, but it is likely due to some installation issues. Here is the new problem and session info


#4

Hi mhanauer,

I think you just need to install the latest dev version of greta from Github with:

devtools::install_github("greta-dev\greta")

(The CRAN version does not work with more recent versions of tensorflow probability.)

Best!


#5

Thanks for the response. So I removed the cran version of greta and then installed the dev version, but unfortunately came across a new problem


#6

lazy load corruption can usually be solved by restarting R and/or redownloading the package

Does that work?

Best!


#7

Ok great I think I am getting closer. It loaded correctly, but now I have a new problem (I have seen this before and haven’t had much luck solving it):


#8

Can you show the full traceback and the versions of tensorflow/tensorflow probability you’re using?


#9

Sure no problem:

tensorflow-probability-0.6.0

tensorflow_1.13.1.9000


#10

This seems to be a known problem with tensorflow,

But that issue also says it should be solved in 1.13.0…

Could you double check your tensorflow version and/or install tf-nightly

Sorry about all the install problems!


#11

I tried installing the the tf-nightly via pip in the command prompt. Is that right way? It still didn’t work same problem. Here is where I pulled tensorflow information from